Neutrino Hot Middleware

NPM version NPM downloads Join Slack

neutrino-middleware-hot is Neutrino middleware for enabled Hot Module Replacement with Webpack's HotModuleReplacementPlugin. This middleware is usually only added during development.

Requirements

  • Node.js v6.9+
  • Yarn or npm client
  • Neutrino v5

Installation

neutrino-middleware-hot can be installed via the Yarn or npm clients.

Yarn

❯ yarn add neutrino-middleware-hot

npm

npm install --save neutrino-middleware-hot

Usage

neutrino-middleware-hot can be consumed from the Neutrino API, middleware, or presets. Require this package and plug it into Neutrino:

const hot = require('neutrino-middleware-hot');

neutrino.use(hot);

Customization

neutrino-middleware-hot creates some conventions to make overriding the configuration easier once you are ready to make changes.

Plugins

The following is a list of plugins and their identifiers which can be overridden:

  • hot: Enables hot module replacement.

Contributing

This preset is part of the neutrino-dev repository, a monorepo containing all resources for developing Neutrino and its core presets. Follow the contributing guide for details.

results matching ""

    No results matching ""